Modern technology gives us many things.

Raspberry Pi 4 Wi-Fi Fails When Using 1440p Video Output

0

There appears to be a problem with the Raspberry Pi 4 — and it’s not the kind of issue you’d expect to surface on this kind of platform. Using 1440p video output apparently makes the Wi-Fi stop working. Enrico Zini, a developer working to create digital signage based on the RBP4. The problem is unique to 1440p — use any resolution below or above that point, and everything works perfectly.

Zini has detailed his work and efforts to repro the bug, noting that they’ve tested three different RBP4’s, multiple cables, multiple cable adapters, four different power supplies, two different operating systems (Raspbian Buster, Raspbian Buster Lite), a phone hotspot, and an AP that was some meters away. In short, they’ve isolated the problem down to the video subsystem pretty thoroughly.

Mike Walters, of Assorted Hackery, performed an analysis of the HDMI output signal at 1080p and 1440p:

There's an interesting story doing the rounds about the Raspberry Pi 4 WiFi not working at higher HDMI resolutions. I had a quick look with a HackRF & near-field probe and there's definitely a big spike that stamps right on channel 1 pic.twitter.com/FXRebYYJxw

— Mike Walters (@assortedhackery) November 28, 2019

Here’s 1080p:

And here’s 1440p:

There’s a giant spike that could easily interfere with Channel 1 of a Wi-Fi adapter. So why is this happening? Because a 2560×[email protected] has a pixel clock of 241.5MHz and has a TMDS (transition-minimized differential signaling) clock of 2.415GHz, according to Hector Martin (@Marcan42). And what frequency does the RBP4 use for Wi-Fi? 2.4GHz. Which means… outputting on HDMI over 1440p can cause interference in a Wi-Fi channel.

2560×[email protected] has a pixel clock of 241.5 MHz, TMDS clock of 2.415 GHz, and suddenly your Raspberry Pi 4 can't use 2.4GHz WiFi and 1440p at the same time, because EMI is hard.

I guess the RPi foundation *still* can't design hardware.
https://t.co/zruafCHgYb

— Hector Martin (@marcan42) November 28, 2019

Apparently this issue can be endemic to USB 3.0 hardware. Intel has released a whitepaper specifically discussing the problem of USB noise and its impact on 2.4GHz and 5GHz wireless operations. The Intel whitepaper notes that a USB 3.0 hard drive can have a significant performance impact on a nearby wireless mouse. I may have run into this problem with wireless devices and USB 3.0 a few times, now that I’ve encountered it in this context. It would explain some odd peripheral behavior I’ve seen when certain USB 3.0 devices are simultaneously plugged in together.

The workaround, for the moment, would be to use a different resolution or refresh rate. Anything other than 1440p should work, and a 50Hz or 30Hz refresh rate would make 1440p work as well. Also, MacBooks (of at least some vintages) apparently suffer from this issue as well — it’s not unique to the RBP Foundation. There’s no word yet on any kind of fix or workaround. Clearly the RBP foundation made a mistake here — this problem may occur in multiple contexts, but most systems don’t suffer complete Wi-Fi drop out just because you change the display resolution. Between the USB-C cable issue and this, it would seem RBP has some easy fixes on the table when it comes time to build the Raspberry Pi 4+ variant.

Now Read:

  • The Raspberry Pi 4 Has a Flawed USB-C Port
  • At a Glance: Raspberry Pi 4 Review
  • Raspberry Pi 4 Launches With More Powerful Processor and 4K Video

Leave A Reply

Your email address will not be published.